Rapid 3D Modeling: Print an Action Figure

Challenge Problem and Resources

Developed by:

The teachers, students, and mentors in the Gaming Research Integration for Learning Laboratory™ (GRILL™)
Summer 2014
# TABLE OF CONTENTS

1. **CHALLENGE PROBLEM: PRINT AN ACTION FIGURE** .......................................................... 3

2. **TUTORIALS** .................................................................................................................. 4
   2.1. **FULL-BODY SCAN WITH KINECT** ............................................................................... 4
   2.1.1. Scanning.................................................................................................................. 4
   2.1.2. Preparing the Skanect Model .................................................................................. 5
   2.2. **CREATING AN ACTION FIGURE** ............................................................................... 6
   2.2.1. Slicing the model.................................................................................................. 6
   2.2.2. Troubleshooting the sliced model ......................................................................... 9
   2.2.3. Adding the Ball and Socket to the Legs ................................................................. 10
   2.2.4. Adding the Ball and Socket to the Torso ............................................................... 10
   2.2.5. Placing Legs on the Action Figure ..................................................................... 11
   2.2.6. Creating movable arms ....................................................................................... 11
   2.3. **KINECT SCANS TO CUBE ERROR** ....................................................................... 13

1. CHALLENGE PROBLEM: PRINT AN ACTION FIGURE

Utilizing off-the-shelf technology, modify a full-body scan to create an action figure of a person with parts than can be posed and then printed using a 3D printer. Suggested tools include a Kinect, with Skanect and SketchUp, and a Cube 3D printer. Solutions to this problem should enable students to complete a full-body scan using a Kinect, import and modify the figure with SketchUp, and print the action figure using a 3D printer.
2. TUTORIALS

Wright Scholars, in collaboration with educators and the GRILL™ team, created the tutorials described below as possible solutions to solve the challenge problem. At the time of creation these were working tutorials; however, with software updates and changes in technology, additional steps may be required. Teachers are encouraged to communicate any issues, problems, or suggested changes to these tutorials to ensure the dissemination of helpful materials to support challenge problem implementation.

2.1. FULL-BODY SCAN WITH KINECT

This tutorial shows how to capture a full color 3D model of a person using Kinect for Windows and prepare it for importing into a modeling software program or game engine. Suggested tools for this challenge problem include Microsoft Kinect for Windows, Kinect SDK, Skanect, and a rotating platform (e.g. moving dolly).

This tutorial includes the following topics:

- Scanning (Section 2.1.1)
- Preparing the Skanect model (Section 2.1.2)

2.1.1. SCANNING

1. Connect the Kinect to a USB port and a power source.
2. Open Skanect. It should detect Kinect.
3. Click the New tab and adjust the settings according to the image below:

![Skanect Image]

Note: The Bounding box may be adjusted and the Path may be different than as shown.
4. Select Start.

5. Have the person being scanned stand on the rotating platform and turn the platform so that the camera is pointed at the person’s side.
   - The Kinect camera should be approximately 2-3 feet away from the person being scanned.
   - Make sure that the person is centered in the bounding box (anything outside of the box will not be scanned).

   **Note:** If you wish to animate your model, make sure that the person’s arms are not touching their sides and their legs are apart.

6. Point the camera at the person’s waist initially.

7. To record, select the red box at the top left of the screen.
   - At this point, the person being scanned must remain perfectly still.
   - Objects being scanned will appear in green, red areas represent missing data.

8. The person scanning should use slow, smooth motions and should move the camera to the person’s head, down to their feet, and then back up above their waist.

9. At this point, another person should rotate the platform about 45 degrees.
   - The person’s face should be scanned last so the platform should initially be rotated so that the camera is pointed toward his/her back.
   - Keep the spinner out of the frame of the Kinect camera.

10. Continue to rotate the platform at 45-degree increments until the person is back to the original position.

   **Note:** It may be necessary to scan the top of the person’s head, so the person scanning may need to angle the Kinect camera so that it captures this view. For best results, rotate the platform 360 degrees very slowly with the Kinect pointed at the top of their head.

---

**2.1.2. PREPARING THE SKANE**

---

PRINT AN ACTION FIGURE

Distribution A.

5
Once the Kinect scan is complete, do the following in Skanect:

2. Go to Process > Geometry > Simplify and reduce the number of faces to 62,000 and press Run.
4. Go to Share > Local > Save. Save the file somewhere easy to locate, such as the desktop.
5. Go to Share > Local > Export Model > Export (or with the free version, Share > Local > Export Preview > Export) and name your file.
   a. If printing, the file should have an .stl extension.
   b. If importing to Unity, the file should have an .obj extension.

### 2.2. CREATING AN ACTION FIGURE

Once you have created a scan of a person, an action figure of a person with parts that can be posed in various positions can then be printed on a 3D printer. Any range of joints is possible, from pin/peg swivel joints to true ball and socket joints. Each printer will have a different limit of joints it can print. This tutorial deals solely with creating an action figure with moveable legs. Recommended software includes file of scanned figure as an .stl file, SketchUp STL Importer, SketchUp STL Exporter, Zorro2 Plugin, and model of a ball and socket joint such as the one from Thingiverse.

This tutorial includes the following topics:

- Slicing the model (Section 2.2.1)
- Troubleshooting the sliced model (Section 2.2.2)
- Adding the ball and socket to the legs (Section 2.2.3)
- Adding the ball and socket to the torso (Section 2.2.4)
- Placing legs on the action figure (Section 2.2.5)
- Creating movable arms (Section 2.2.6)

Either create a scan specifically for this project or use an already existing one, ensuring that the model has no holes and that the model consists of an exterior skin.

#### 2.2.1. SLICING THE MODEL

1. Open Sketchup if it is not already open.
2. Import the .stl file of the model, File→Import.
3. Using the Rectangle tool, create a rectangle through the legs just below the point where they separate. Ensure that the rectangle completely cuts through the model. For best
results, make sure that the model has no other parts except the legs underneath the plane defined by the rectangle.

**Note:** This rectangular plane will define the cutting plane by which the model will be sliced. Everything above the plane will be printed as one part, while everything below, in this case the two legs, will be printed separately. The plane also marks where the ball and socket joints will be placed. While the model in this tutorial has one such place where joints will be placed, a model can be made with as many joints as the creator wishes to place.

4. Copy the model and cutting plane so that the cutting plane of the first is below the bottom of the second model, and so that the cutting plane of the second is above the top of the first, or vice versa.
5. Press *Ctrl A* to select the entire object and then select the move tool and press control. A plus sign should appear next to the cursor.
6. Select the character and move it aside and a copy will display. It should look something like the image below, left.

**Note:** The cutting of the models works in such a way that it keeps everything on a chosen side of the plane, and deletes everything on the other side, regardless of whether or not it is connected to the model being sliced or not. For complex models with a large number of joints, enough models should be created to have one from which each separate part can be created. Make sure that the parts are placed in such a position that when cut, nothing else will be deleted. Be sure to save what is being removed from the current model.
7. Place two section planes (Tools ➔ Section Plane) on the rectangular planes so that the legs will be removed from the model that is on the bottom and the torso will be removed from the model on the top.

8. In the image above left, active cut is not enabled, so the models do not look like they will when cut. To fix this, right click and make sure active cut is checked. Use active cut to make sure the cut is going in the right direction, picture above right.

9. Right click on each section plane and select the “Slice Model at Section” option. This will cause the model to be sliced along the section plane. Do this for both models.

10. Delete the section planes and the rectangles. The result should look like the picture below.
2.2.2. TROUBLESHOOTING THE SLICED MODEL

Now that the model is sliced, it should be noted what the model should NOT look like. In the picture below, it can be seen that the model has an “interior skin.” This is due to the model having a hole that it cannot patch, and in an attempt to make itself solid, it will create such a model. To fix this, you will have to find and delete the point(s) where the interior and exterior are connected. The interior will then be separate and you will be able to delete it from the model. The picture on the right is correct, and is what the model should look like.

To disconnect the interior hollow of the model from the exterior skin:

1. Search for a hole in the model. This will require thorough combing of the model to find the holes. Unfortunately, there is no other technique known at this time to find holes. However, highlighting and copying sections of the model to see if the interior and exterior are connected can narrow down the area where the hole is. In the pictures below, a hole can clearly be seen connecting the inside and outside. Most of the model has been hidden so that it can better be seen.

2. Once you have found a hole, delete everything connecting the inside and outside. Below is an example.

   Note: There may be more than one hole, depending on the model. Verify whether or not
the inside and outside are connected after removing each hole.

### 2.2.3. ADDING THE BALL AND SOCKET TO THE LEGS

1. Download the ball and socket joint. Start with the legs. Import the .stl files of the ball and socket joint into SketchUp. Scale the parts of the joint up or down to fit the model, but be sure that they are the same size so they will properly fit together. There is no optimal size, but they should be test printed to ensure they will properly print and fit together.

2. Seal the holes created by the slicing starting with the legs. Draw lines between the vertices on the edges of the legs to create triangles and seal the top. It does not have to be perfectly level, but it should be fairly level.

3. Next, move the ball part of the joint and place it on top of one of the legs, somewhere close to the center.

4. Copy the part and move it to a similar spot on the other leg. The finished legs should look like the picture below and may require some modifications prior to being printed.

5. Copy the part and move it to a similar spot on the other leg. The finished legs should look like the picture below and may require some modifications prior to being printed.

### 2.2.4. ADDING THE BALL AND SOCKET TO THE TORSO

1. Flip the socket joint upside down, and move it so that it perfectly lines up with the ball. Hold down shift key while moving the part can restrict its movement along a specific axis and allow it to line up with the part.

2. Copy the socket and match it up with the other ball.

3. Make the two sockets a group or component by right clicking and selecting Make Group or Make Component so they will always move together.
4. Maneuver the sockets so that they are directly underneath the torso, correspond them with the balls on the legs. Then move them along the blue axis, bringing their bottoms (the top of the slots) in line with the bottom of the torso model.

5. Create a small, flat area around the outer radius of the interior of the leg. This will provide cross-sectional area for the printer to begin with. Also, edit the sockets so that they have a level bottom.

6. Explode the sockets until their polygon structure is highlighted.

7. Draw lines from the flat area of the torso to the base of the socket to create a cone around the socket. Go all the way around, making the torso one whole model. The torso should look like the picture below.

**Note:** This step may need some trouble shooting. If the model is printed too small, the sockets will merge with the conic walls of the torso, preventing the ball from slipping in easily. It may be helpful to isolate the bottom part of the torso with just the sockets, isolate the ball, and print a test piece of both to insure that the ball can fit nicely in the socket. Scale the model as needed.

---

**2.2.5. PLACING LEGS ON THE ACTION FIGURE**

1. Export the model as an .stl file.
2. Print all pieces
3. Push the ball into the socket for each leg. It may take a great amount of force to get it in the first time.

You now have an action figure with legs that you can pose!

**2.2.6. CREATING MOVABLE ARMS**
Similar to moveable legs, you can create movable arms using a ball and socket joint. However, since they are not placed vertically the process becomes a bit more complicated. You can modify these processes to create action figures with any variation of horizontal joints. You can use the same model used for the previous tutorial if the arms are separate. They must be not touch the rest of the model.

1. Create a rectangular plane to use as the cutting plane to separate the arm from the torso.
2. Create an extra copy of the model for each arm.

Notes:
- All of the rules about placement of section planes and cutting from the previous section still apply. In this case, the rectangular plane may have to be rotated in order to more precisely slice through the shoulder properly.
- Sometimes, Zorro2 has not worked properly, and will create lines on the model where it would be cut, but the model will not actually be cut. In this case, either manually disconnect the two pieces along the plane, or right click on the rectangular plane and select “Intersect Faces”. This should create lines along the model that match with the rectangular plane, which makes for a clean cut. Sometimes, this method is preferred, as cutting the model may slice certain pieces off of the torso in addition to slicing off the arm.
3. Attach the ball socket to the arm, and embed the socket in each shoulder. Once again, make sure they match up to ensure the best fit.
4. Rotate the arm to make it easier to print. It is helpful to add in supports when printing to save on time and material. The picture below is an example of an arm in a sideways position with supports.
5. Embed the sockets in the shoulder and fill in the model. Below is an example of what the torso should look like. Most of the torso has been removed and the socket has only been applied to one arm for testing purposes.

6. Print both the arm and torso and clean the model by removing any supports.

**Note:** If printing on the Cube, supports MUST be turned on; otherwise the socket will not print properly.

---

### 2.3. KINECT SCANS TO CUBE ERROR

Once a 3D model is imported into Cube Software an error can occur declaring there is an incorrect input string. If this occurs, use this tutorial to resolve the issue. Recommended software includes SketchUp, SketchUp STL Importer, 3ds Max®, and Cubify Cube Software. Follow the steps indicated below to save and export files for printing.

1. Download and install SketchUp STL Importer plugin and place the plugin in C:\Program Files (x86)\Google\Google SketchUp 8\Plugins.
2. In SketchUp, go to File → Import and select the desired STL file. Select the file type, STL Importer (*.stl) by Jim Foltz, and click Open.
3. The model may initially appear very small so it is necessary to zoom and scale it 50-100 times its original size. If necessary, build supports here for the model. Save the model as an .skp file by saving it as the default file type.
4. Open 3ds Max®, import the .skp file by going to the top left file menu and selecting Import.
5. Select the object and press Okay on the next screen.
6. Export the object as an .stl file by going to the file menu, selecting Export, and change the file type to .stl. Make sure the object is selected.
7. Import the .stl file into Cube Software and continue preparing the model.
8. Build the file as a .cube file and save to a flash drive in order to print from the Cube 3D printer.